Jump to content
hobnob11

[Guide] Fix BAD_MODULE_INFO Crash! (Disable Full-Screen Optimizations)

Recommended Posts

(TL;DR, scroll down to the bullet points)

 

oBS2B1B.png

 

After I heard that this could be fixed by disabling a windows compatibility option, I decided to do some research into what exactly was happening. I have found no reliable way to cause this, so local testing is pretty difficult. From what I can gather from online forums and posts by people having the same crash report, It's something related to Battle-eye and how windows handles full screen applications, as this happens in other battle-eye protected games such as fort-nite and DayZ. The error itself is a windows system error, but beyond that MSDN is being typically unhelpful.

 

Anyways, Onto the "Supposed may or may not work probably will results may vary :TM:" fix.

 

  1. Open your Arma 3 Folder, this is by default located in: (If you have moved your steam installation, I will assume you know how to find your steam apps folder.)
    C:\Program Files (x86)\Steam\steamapps\common\Arma 3

     

  2. Right click on the first .exe file you see (arma3.exe) and click properties.
    image.png.938215f96415a62416e740ad05a6e53a.png

  3. Go to the Compatibility tab, and select "Change settings for all users"
    image.png.e3188b9718bf3a6a235cfbea1d75cb9b.png

  4. Check "Disable full-screen optimisation", and then click Apply.
    image.png.051fb5bb6284d372a8736e054b5dbce1.png

  5. You must now repeat this step for all other .exe files in your base ArmA folder.
    image.png.d313a33a23444880b711efda13d3b5c7.png

 

I can't grantee that this will permanently fix the issue, but I can confirm that this has no performance impact what-so-ever so there should be no downside to this.

 

 

Share this post


Link to post
Share on other sites

I got mine completely fixed by setting up 2 gigs (2048 Mb) Virtual Memory, before that I had it disabled.
I have 16 gigs memory so I should not run out but according to system logs I found in the event log I did.

You can do this with win + R  -> SystemPropertiesAdvanced.exe -> "Performance" Settings -> Advanced tab -> "Virtual Memory" Change
I enabled it for my C drive (ssd) and used initial value 2048 | max value 4096 (reboot like the warning says :) )

No more crashes since (8 straight hours of Arma as evidence)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Forum Statistics

    9,350
    Total Topics
    60,451
    Total Posts
×
×
  • Create New...