Jump to content

Memory leaks and shiz


 Share

Recommended Posts

As a pilot, you're moving a lot faster than infantry, so all these textures need to be loaded faster and more often. Once loaded, they'll be put in your RAM, because your computer would need too much time to retrieve them from your HDD/SSD every single time.

 

Also, because you move faster and have access to long range weapons, you need a longer view distance. Instead of all objects in a 1500m radius (infantry setting), it has to render and texture all objects in a 5000m radius (pilot setting). This is not a linear, but an exponential increase in objects, especially around dense areas (bigger cities or forests).

 

 

Quite easy to run out of memory like that...

Link to comment
Share on other sites

  • 2 weeks later...

I hate to say it but to me that looks no different than a classic case of a memory leak that spiraled out of control and royally screws you about every 20 mins. It also looks your system is rolling with a pretty low amount of ram, which of course isn't the best (It looked like 4gb but I could be very wrong), so one thing that has helped me as 8 of my 16gb's of ram decided to take a shit on itself a while back is only have open your game and TS. Other programs, especially chrome, really eats memory that arma wants. 

Sorry that this keep happening but it has just become a part of the game. You can also try and set your memory allocator to 'system' which could help. 

-Ben

Link to comment
Share on other sites

On 1/31/2017 at 6:00 PM, BenjaminHL said:

I hate to say it but to me that looks no different than a classic case of a memory leak that spiraled out of control and royally screws you about every 20 mins. It also looks your system is rolling with a pretty low amount of ram, which of course isn't the best (It looked like 4gb but I could be very wrong), so one thing that has helped me as 8 of my 16gb's of ram decided to take a shit on itself a while back is only have open your game and TS. Other programs, especially chrome, really eats memory that arma wants. 

Sorry that this keep happening but it has just become a part of the game. You can also try and set your memory allocator to 'system' which could help. 

-Ben

You are very wrong, I have 16gb of ram in my pc. I run the game on mostly 50-60fps on very high/ulta settings with 5km view distance, I doubt it's my computer thats causing the leaks as it runs the game supersmooth for about 20min and then Arma happens. I also tried almost, if not all, ways to "fix" these leaks I could find on the internet. None of them seems to have an effect.

 

Only thing that is a bit outdated is my monitor I'd say.
 
And it's as Winter said, I ran the game with no trouble whatsoever untill an update happened around mid November. That's when it all started for me.

 

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Forum Statistics

    11.1k
    Total Topics
    66.4k
    Total Posts
×
×
  • Create New...