Jump to content

Can't join EU3 even with mods installed


Recommended Posts



I have been having a few issues today trying to join the eu3 modded server. 


I was last able to get on to it on the game night on Saturday, I had a few issues involving team-speak not working and after re - installing it twice over ( Including TFAR) I think its now fully sorted. 


When I tried to load up EU3 ttoday to play and make sure team - speak was working, it wouldnt let me connect through arma3 sync. Normally i can click to join then when it says use battle eye the game reboots which then gets me onto the server, this has worked for ages before last Saturday, but since Saturday it hasn't let me connect to the server at all. Even when launching through steam. 


Can anyone help me out ? 

I love playing on eu3 and being a noob to pc gaming i'm not used to all the faff which comes with it at times. 


Many thanks 


Link to comment
Share on other sites

1.Important: after every update including adding or removing addons! ->In arma3sync in "Addons" tab click modsets on right side select Ahoyworld Moded and tick every box of the mod. If there is update of addons including new ones or removing one of them you should check if you have ticked every mod in repository.

2. Go to the "Launcher option" tab. Choose everything you need from performance and tick boxes on your profile and check signatures.

Important: game not running at all! -> In additional parameters write "0 1". You'll see if you remove additional parameters the game won't run. It will do actually = nothing.

3. Important: Game restarts for launching of battleye! For game location (on bottom of "Launcher options" tab) pick arma3battleye.exe so you don't have to launch it separately.


After this point I don't know what can cause of game not running except hardware drivers or corrupted core Windows stuff. I'm taking that you have installed all properly from the tutorial for arma3sync.

Link to comment
Share on other sites

I did a complete mod uninstall and re installed them all, just having issues with tfar in game, ie not able to open the radio at the moment. It said i was missing something from teamspeak 3 for some reason. Might just need to ren install it 


thanks for the help guys 

Link to comment
Share on other sites

When I've first installed mods I had problem with TFAR and Teamspeak. Even when I thick boxes for TFAR plugin I still had the same error poping on teamspeak. I was lazy so I've just reinstalled teamspeak, then again TFAR on top of it. It worked. Then there was an TFAR update. Same procedure and it worked again.

If you can run TFAR from TS without having issues except ones when you are in game. Try what @MessedUpSmiley suggested.

Link to comment
Share on other sites

Quick update 

I used the steam launcher to load game / mods that way and it worked, only issue was teamspeak saying that it was missing a plugin and not working on windows for some reason. It did work whilst i was on eu3 though, so who know what's causing the issue.   -_-  -_-


Thanks for the help guys, it's really appreciated. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Forum Statistics

    Total Topics
    Total Posts
  • Create New...