Jump to content
Owenxpl

Problem with TFAR and plane pylons

Recommended Posts

Hi, I'm trying to add Task Force Radios to the mission but i have problem with this model "tf_prc152". Wherever i add, this script remove it from inventory (it's visible in arsenal).

 

i'm using TFAR 0.9.12

whitelistArray = ["tf_anprc152"];


 

generalItems = [
//Optics:
"optic_Aco", "optic_ACO_grn", "optic_ACO_grn_smg", "optic_Aco_smg", "optic_Arco", "optic_Arco_blk_F", "optic_Arco_ghex_F", "optic_ERCO_blk_F",
"optic_ERCO_khk_F", "optic_ERCO_snd_F", "optic_Hamr", "optic_Hamr_khk_F", "optic_Holosight", "optic_Holosight_blk_F", "optic_Holosight_khk_F",
"optic_Holosight_smg", "optic_Holosight_smg_blk_F", "optic_Holosight_smg_khk_F", "optic_MRCO", "optic_NVS", "optic_Arco_arid_F",
"optic_Arco_lush_F", "optic_Arco_AK_arid_F", "optic_Arco_AK_blk_F", "optic_Arco_AK_lush_F", "optic_Holosight_arid_F", "optic_Holosight_lush_F",
"optic_MRD_black", "optic_ico_01_f", "optic_ico_01_black_f", "optic_ico_01_camo_f", "optic_ico_01_sand_f",

//Accessories:
"acc_flashlight", "acc_flashlight_smg_01", "acc_pointer_IR",
//Suppressors:
"muzzle_snds_338_black", "muzzle_snds_338_green", "muzzle_snds_338_sand", "muzzle_snds_58_blk_F", "muzzle_snds_58_ghex_F", "muzzle_snds_58_hex_F",
"muzzle_snds_65_TI_blk_F", "muzzle_snds_65_TI_ghex_F", "muzzle_snds_65_TI_hex_F", "muzzle_snds_93mmg", "muzzle_snds_93mmg_tan", "muzzle_snds_acp",
"muzzle_snds_B", "muzzle_snds_B_khk_F", "muzzle_snds_B_snd_F", "muzzle_snds_H", "muzzle_snds_H_khk_F", "muzzle_snds_H_snd_F", "muzzle_snds_H_MG",
"muzzle_snds_H_MG_blk_F", "muzzle_snds_H_MG_khk_F", "muzzle_snds_L", "muzzle_snds_M", "muzzle_snds_m_khk_F", "muzzle_snds_m_snd_F", "muzzle_snds_570",
//Bipods:
"bipod_01_F_blk", "bipod_01_F_khk", "bipod_01_F_mtp", "bipod_01_F_snd", "bipod_02_F_blk", "bipod_02_F_hex", "bipod_02_F_tan", "bipod_03_F_blk", "bipod_03_F_oli",
//Handgun Optics:
"optic_MRD", "optic_Yorris",
//Handgun Accessories:
"acc_flashlight_pistol",
//Night Vision Goggles:
"NVGoggles", "NVGoggles_INDEP", "NVGoggles_OPFOR", "NVGoggles_tna_F",
//Binoculars:
"Binocular", "Rangefinder", "Laserdesignator", "Laserdesignator_01_khk_F", "Laserdesignator_03",
//Map, GPS, Radio, Compass, Watch:
"ItemMap", "ItemGPS", "ItemRadio", "ItemCompass", "ItemWatch",
//Other:
"FirstAidKit", "Medikit", "ToolKit", "MineDetector",
//TFAR:
"tf_anprc152"
];

 

 

Backpacks work well... except "tf_mr_3000_multicam"...

//Backpacks all slots have access to.
generalBackpacks = [
	"B_AssaultPack_blk", "B_AssaultPack_cbr", "B_AssaultPack_khk", "B_AssaultPack_mcamo", "B_AssaultPack_rgr", "B_AssaultPack_sgg", "B_AssaultPack_tna_F",
	"B_Bergen_mcamo_F", "B_Bergen_tna_F", "B_Carryall_cbr", "B_Carryall_khk", "B_Carryall_mcamo", "B_Carryall_oli", "B_FieldPack_blk", "B_FieldPack_cbr",
	"B_FieldPack_khk", "B_FieldPack_oli", "B_Kitbag_cbr", "B_Kitbag_mcamo", "B_Kitbag_rgr", "B_Kitbag_sgg", "B_LegStrapBag_black_F", "B_LegStrapBag_coyote_F",
	"B_LegStrapBag_olive_F", "B_Messenger_Black_F", "B_Messenger_Coyote_F", "B_Messenger_Gray_F", "B_Messenger_Olive_F", "B_Parachute", "B_TacticalPack_blk",
	"B_TacticalPack_mcamo", "B_TacticalPack_oli", "B_TacticalPack_rgr", "B_ViperHarness_blk_F", "B_ViperHarness_khk_F", "B_ViperHarness_oli_F",
	"B_ViperLightHarness_blk_F", "B_ViperLightHarness_khk_F", "B_ViperLightHarness_oli_F", "B_AssaultPack_wdl_F", "B_Carryall_green_F", "B_Carryall_wdl_F", 
	"B_FieldPack_green_F", "B_AssaultPack_eaf_F", "B_Carryall_eaf_F", "B_Carryall_taiga_F", "B_FieldPack_taiga_F", "B_RadioBag_01_black_F", "B_RadioBag_01_mtp_F",
	"B_RadioBag_01_tropic_F", "B_RadioBag_01_wdl_F", "B_RadioBag_01_eaf_F", "B_SCBA_01_F", "B_CombinationUnitRespirator_01_F",

	//TFAR:
	"tf_rt1523g_big_rhs", "tf_rt1523g", "tf_mr_3000_multicam"
];

 

 

And one more.

 

How can i add Gbu12 to Black wasp? I know that i have edit fn_vsetup02.sqf but idk what i have to change.

Share this post


Link to post
Share on other sites

For the radios: go to functions/inventory/fn_cleaninventory.sqf and in the code that removes assigned items and inventory items make an exception for tfar radios.

 

For the gbus on the wasp: have a look at fn_smsuccesshint.sqf, there's a wasp with gbus in there. Just search for the classname

Share this post


Link to post
Share on other sites

When you exit the arsenal tfar takes away the radio you have and gives you one with an almost identical classname but with and underscore and  a random number between 1 and 999 to the end of it.

Share this post


Link to post
Share on other sites

So i need help because idk syntax of sgf  😜

 

I add this 

if ((_x != "") && (_x != "tf_anprc152") && (!(_x in whitelistArray) || (_x in blacklistArray))) then {

 

But i have to add there also any character after tf_anprc152

Share this post


Link to post
Share on other sites

THX 😉

 

If in the future someone will have same problem 

 

//Assigned items:
{	
	if ((_x != "") && ((_x find "tf_anprc152") < 0) && (!(_x in whitelistArray) || (_x in blacklistArray))) then {
		_removedString = _removedString + (getText (configFile >> "CfgWeapons" >> _x >> "displayName")) + "<br/>";
		_removedItems pushBack _x;
		player unassignItem _x;
		player removeItem _x;
	};
	if ((_x == "B_UavTerminal") && ((roleDescription player find "Operator") == -1)) then {
	    player unassignItem _x;
        player removeItem _x;
	};
} forEach (assignedItems player);

 

Share this post


Link to post
Share on other sites

I wouldn't make now topic for one extra question


How can i made like in your second server to arma require TFAR and only allow JSRS?

 

Or even better it will be to make all of the mods will be suggested, but i ques that it will be impossible to make server with TFAR and make it optional...

Share this post


Link to post
Share on other sites

if i remember correctly:

you need to set VerifySignatures to 2 in the server.cfg (0 disables it, 1 does somthing else i cannot remember, 2 checks for the allowed addons)

and then only mods/addons that have a key in your keys folder are allowed on the server.

 

and making TFAR optional is possible, but people that don't use it just won't be able to hear any of the radios nor proximity voice.

Share this post


Link to post
Share on other sites

I just do that but i heven't tested it well. 

I have added all keys, set Verify Signatures v2 and run mods this way -servermod=@task_force_radio;@CBA_A3

Server don't require any mods but you can join with them and you can't connect with any other.

 

2 hours ago, Stanhope said:

I write code...

 And you do it well

 

Quote

1 does somthing else i cannot remember,

In arma 3 it should do exacly the same as 2

 

 

Share this post


Link to post
Share on other sites

to make optional mods allowed you need to add the .bikey for the mod to the servers keys folder. TFAR as said above will introduce communication issues if people dont have it installed.

Share this post


Link to post
Share on other sites

I hope that this will not be a problem when I continue asking in this topic.

 

How can I incrase Amount of infantry groups on the main AO over 10? Adding extra options in "Description.ext" seems doesn't work.

 

How can I remove that info? RIsZgP0.png

Share this post


Link to post
Share on other sites
20 minutes ago, Owenxpl said:

How can I incrase Amount of infantry groups on the main AO over 10?

functions/AI/fn_mainAOSpawnHandler.sqf

21 minutes ago, Owenxpl said:

Adding extra options in "Description.ext" seems doesn't work.

Assume nothing in the options in description.ext works but don't delete any or everything will break.

22 minutes ago, Owenxpl said:

How can I remove that info?

It doesn't show in normal I&A 3 so it's something you changed

Share this post


Link to post
Share on other sites

So if this file "fn_mainAOSpawnHandler.sqf" set amount of enemies what changes are made by changing "Amount of infantry groups on the main AO" in 
parameters?

Share this post


Link to post
Share on other sites

None whatsoever.  I&A 3 is a mission that's several years old now and has been maintained by several people who all do things differently.  As I know that AW doesn't ever change those parameters I see no need to use them and work with hard coded values. 

Share this post


Link to post
Share on other sites

Hmm Why when i have 3 players, mission spawns planes? 

 

 

//Determine how many units to spawn:
private _amountOfPlayers = count allPlayers;
private ["_MBTs","_AAVics","_IFVs","_Cars","_mainInf","_AAinf","_ATinf","_recon","_helis","_jet"];

switch true do {
	case (_amountOfPlayers <= 3):{
		_MBTs = 0;
		_AAVics = 0;
		_IFVs = 0;
		_Cars = 2;
		_mainInf = 5;
		_AAinf = 1;
		_ATinf = 1;
		_recon = 1;
		_helis = 0;
		_jet = false;
	};
	case (_amountOfPlayers > 3 &&_amountOfPlayers <= 6):{
		_MBTs = 1;
		_AAVics = 0;
		_IFVs = 1;
		_Cars = 1;
		_mainInf = 5;
		_AAinf = 1;
		_ATinf = 1;
		_recon = 1;
		_helis = 0;
		_jet = false;
	};
	case (_amountOfPlayers > 6 && _amountOfPlayers <= 15):{
		_MBTs = 1;
		_AAVics = (0 + round (random 1));
		_IFVs = (1 + round (random 1));
		_Cars = (1 + round (random 1));
		_mainInf = 6;
		_AAinf = 1;
		_ATinf = 1;
		_recon = 2;
		_helis = 0;
		_jet = false;
	};
	case (_amountOfPlayers > 15 && _amountOfPlayers <= 30):{
		_MBTs = 1;
		_AAVics = (1 + round (random 1));
		_IFVs = (0 + round (random 1));
		_Cars = (1 + round (random 2));
		_mainInf = 7;
		_AAinf = 2;
		_ATinf = 2;
		_recon = 1;
		_helis = 0;
		_jet = selectRandom[true, false, false];
	};
	case (_amountOfPlayers > 30 && _amountOfPlayers <= 40):{
		_MBTs = 1;
		_AAVics = 2;
		_IFVs = 2;
		_Cars = 3;
		_mainInf = 8;
		_AAinf = 2;
		_ATinf = 2;
		_recon = 2;
		_helis = 0;
		_jet = selectRandom[true, false, false];
	};
	case (_amountOfPlayers > 40 && _amountOfPlayers <= 50):{
		_MBTs = 1;
		_AAVics = (2 + round (random 1));
		_IFVs = (2 + round (random 1));
		_Cars = (3 + round (random 1));
		_mainInf = 9;
		_AAinf = 2;
		_ATinf = 2;
		_recon = 3;
		_helis = 1;
		_jet = selectRandom[true, true, false];
	};
	case (_amountOfPlayers > 50):{
		_MBTs = 2;
		_AAVics = (2 + round (random 2));
		_IFVs = (2 + round (random 2));
		_Cars = (3 + round (random 2));
		_mainInf = 10;
		_AAinf = 3;
		_ATinf = 3;
		_recon = 4;
		_helis = 2;
		_jet = true;
	};
};

 

 

aBqph4z.jpg

Share this post


Link to post
Share on other sites

It have AAA But now i guess that something was bugged becouse it spawn 5 planes... and after this mission it's look like everything is back to normal.

Share this post


Link to post
Share on other sites

Ok it happend second time it spawn 4 jets every time after server restart. I skipped some mission by deleting the units and killing sub-objective and that whats happend. I have to check how it will looks like if we play the mission without deleting units and killing subobjective.

 

 

ob1yhDA.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Forum Statistics

    9,391
    Total Topics
    60,709
    Total Posts
×
×
  • Create New...